Yahoo! Photo Mail

Marc Canter noted on his weblog that Yahoo!’s new Photo Mail service is available for the 100M Yahoo! Mail users. It only works if you’ve got Windows 2000 or XP with the Internet Explorer browser [version 5.5 and higher]. My iBook and I are apparently out of luck.

Quick Select is the browser software that enables PhotoMail. Quick Select is only available for PC users running Windows 2000 or XP with the Internet Explorer browser [version 5.5 and higher]. Quick Select Tool and PhotoMail are not available for Firefox, Netscape, and Macintosh users. If you do meet the requirements outlined above, please try closing all open browser windows and restarting Internet Explorer. Then visit Yahoo! Mail and try installing the Quick Select Tool again.

Author: Sooz

I'm Sooz.